Read the docs
TI-2021-18447 Aliases CVE-2021-41824GHSA-h7vq-5qgw-jwwq

Craft CMS before 3.7.14 allows CSV injection.

Priority MEDIUM 41CWE-1236Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Craft CMS before 3.7.14 allows CSV injection.

Why it matters now

EPSS 0.01373 72nd percentileScored 2026-11-07
Fix Fixed craftcms/cms (Packagist): 3.7.14

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—craftcms/cms (Packagist)3.4.0 to before 3.7.143.7.14Patch availableGHSA-h7vq-5qgw-jwwq
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • craftcms/cms (Packagist) Vendor— Affected 3.4.0 to before 3.7.14 Fixed in 3.7.14 Patch available GHSA-h7vq-5qgw-jwwq

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:*3.4.0 to before 3.7.14VulnerableCraft CMS
  • cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions 3.4.0 to before 3.7.14 Vulnerable ·Craft CMS

Remediation

  • Fix · GHSA-h7vq-5qgw-jwwq craftcms/cms (Packagist) Fixed in 3.7.14 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-41824
  2. 2026-10-03 Alias added: GHSA-h7vq-5qgw-jwwq

References

  • TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
  • TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
  • TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
  • TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
See all 96 →

Sources