Read the docs
TI-2022-00145 Aliases CVE-2022-0208GHSA-3c8f-rp5x-hvrg

MapPress Maps for WordPress < 2.73.4 - Reflected Cross-Site scripting

Priority LOW 31CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The MapPress Maps for WordPress plugin before 2.73.4 does not sanitise and escape the mapid parameter before outputting it back in the "Bad mapid" error message, leading to a Reflected Cross-Site Scripting

Why it matters now

EPSS 0.02031 81st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed MapPress Maps for WordPress (Unknown): 2.73.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownMapPress Maps for WordPress2.73.4 to before 2.73.42.73.4Patch availableCNA
  • MapPress Maps for WordPress VendorUnknown Affected 2.73.4 to before 2.73.4 Fixed in 2.73.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mappresspro:mappress:*:*:*:*:*:wordpress:*:*before 2.73.4Vulnerablechrisvrichardson
  • cpe:2.3:a:mappresspro:mappress:*:*:*:*:*:wordpress:*:* Versions before 2.73.4 Vulnerable ·chrisvrichardson

Remediation

  • Fix · CNA MapPress Maps for WordPress (Unknown) Fixed in 2.73.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0208
  2. 2026-10-03 Alias added: GHSA-3c8f-rp5x-hvrg

References

  • TI-2025-01793 MapPress Maps for WordPress < 2.94.9 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.8
  • TI-2023-05979 MapPress Maps for WordPress <= 2.88.13 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
  • TI-2025-01894 MapPress Maps for WordPress < 2.94.10 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-07996 MapPress Maps for WordPress < 2.93 - Admin+ Stored XSS via Map Settings CVSS 3.1MEDIUM 4.8
  • TI-2023-11256 WordPress MapPress Maps for WordPress Plugin <= 2.85.4 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
  • TI-2020-09728 The mappress-google-maps-for-wordpress plugin before 2.53.9 for WordPress does not… CVSS 3.1HIGH 8.8
See all 11 →

Sources