Ad Inserter < 2.7.10 - Reflected Cross-Site Scripting
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Ad Inserter WordPress plugin before 2.7.10, Ad Inserter Pro WordPress plugin before 2.7.10 do not sanitise and escape the html_element_selection parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting
Why it matters now
EPSS 0.02061 81st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Ad Inserter – Ad Manager & AdSense Ads (Unknown): 2.7.10Ad Inserter Pro (Unknown): 2.7.10
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ad Inserter – Ad Manager & AdSense Ads | 2.7.10 to before 2.7.10 | 2.7.10 | Patch available | CNA |
| Unknown | Ad Inserter Pro | 2.7.10 to before 2.7.10 | 2.7.10 | Patch available | CNA |
- Ad Inserter – Ad Manager & AdSense Ads VendorUnknown Affected 2.7.10 to before 2.7.10 Fixed in 2.7.10 Patch available CNA
- Ad Inserter Pro VendorUnknown Affected 2.7.10 to before 2.7.10 Fixed in 2.7.10 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ad_inserter_pro_project:ad_inserter_pro:*:*:*:*:*:wordpress:*:* | before 2.7.10 | Vulnerable | Ad Inserter Pro Project |
| cpe:2.3:a:ad_inserter_project:ad_inserter:*:*:*:*:*:wordpress:*:* | before 2.7.10 | Vulnerable | Ad Inserter Project |
- cpe:2.3:a:ad_inserter_pro_project:ad_inserter_pro:*:*:*:*:*:wordpress:*:* Versions before 2.7.10 Vulnerable ·Ad Inserter Pro Project
- cpe:2.3:a:ad_inserter_project:ad_inserter:*:*:*:*:*:wordpress:*:* Versions before 2.7.10 Vulnerable ·Ad Inserter Project
Remediation
- Fix · CNA Ad Inserter – Ad Manager & AdSense Ads (Unknown) Fixed in 2.7.10
- Fix · CNA Ad Inserter Pro (Unknown) Fixed in 2.7.10
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0288
- 2026-10-03 Alias added: GHSA-f6p6-h7v7-mpgx
References
Sources
- CVE-2022-0288 · CVE Program
- CVE-2022-0288 · NVD
- FIRST EPSS
- GHSA-f6p6-h7v7-mpgx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences