The Ad Inserter WordPress plugin before 2.7.27 unserializes user input provided via the settings, which could allow high privilege users such as admin to perform PHP Object Injection when a suitable gadget is present
CVSS 3.1HIGH 7.2·Network·High privileges·No interaction·EPSS 0.16903·Published 2023-05-15·Fixed in 2.7.27
The Ad Inserter for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 2.7.30 via the ai-debug-processing-fe URL parameter.
The Ad Inserter Free and Pro WordPress plugins before 2.7.12 do not sanitise and escape the REQUEST_URI before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting in browsers which do not enc…
CVSS 3.1MEDIUM 6.1·Network·No auth·User interaction·EPSS 0.03596·Published 2022-04-04·Fixed in 2.7.12CWE-79
The Ad Inserter WordPress plugin before 2.7.10, Ad Inserter Pro WordPress plugin before 2.7.10 do not sanitise and escape the html_element_selection parameter before outputting it back in the page, leading to a Reflected…
CVSS 3.1MEDIUM 6.1·Network·No auth·User interaction·EPSS 0.02061·Published 2022-02-21·Fixed in 2.7.10CWE-79