Incorrect authorization in moodle
Priority LOW 19CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. The calendar:manageentries capability allowed managers to access or modify any calendar event, but should have been restricted from accessing user level events.
Why it matters now
EPSS 0.00641 50th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.11.5, 3.10.8, 3.9.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | moodle 3.11.5, moodle 3.10.9 and moodle 3.9.12 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.11 to before 3.11.5 | 3.11.5 | Patch available | GHSA-m434-m5pv-p35w |
| — | moodle/moodle (Packagist) | 3.10 to before 3.10.8 | 3.10.8 | Patch available | GHSA-m434-m5pv-p35w |
| — | moodle/moodle (Packagist) | 3.9 to before 3.9.11 | 3.9.11 | Patch available | GHSA-m434-m5pv-p35w |
- moodle Vendor— Affected moodle 3.11.5, moodle 3.10.9 and moodle 3.9.12 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.5 Fixed in 3.11.5 Patch available GHSA-m434-m5pv-p35w
- moodle/moodle (Packagist) Vendor— Affected 3.10 to before 3.10.8 Fixed in 3.10.8 Patch available GHSA-m434-m5pv-p35w
- moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.11 Fixed in 3.9.11 Patch available GHSA-m434-m5pv-p35w
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | up to 3.8.9; 3.9.0 to before 3.9.12; 3.10.0 to before 3.10.9; 3.11.0 to before 3.11.5 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 3.8.9; 3.9.0 to before 3.9.12; 3.10.0 to before 3.10.9; 3.11.0 to before 3.11.5 Vulnerable ·Moodle
Remediation
- Fix · GHSA-m434-m5pv-p35w moodle/moodle (Packagist) Fixed in 3.11.5 Advisory →
- Fix · GHSA-m434-m5pv-p35w moodle/moodle (Packagist) Fixed in 3.10.8 Advisory →
- Fix · GHSA-m434-m5pv-p35w moodle/moodle (Packagist) Fixed in 3.9.11 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0333
- 2026-10-03 Alias added: GHSA-m434-m5pv-p35w
- 2026-10-21 EPSS moved to the 50th–90th percentile
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2022-0333 · CVE Program
- CVE-2022-0333 · NVD
- FIRST EPSS
- GHSA-m434-m5pv-p35w · GitHub Advisory Database · CC BY 4.0
- CVE-2022-0333 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences