Read the docs
TI-2022-00262 Aliases CVE-2022-0335GHSA-xpfv-89vg-r562

Cross-site request forgery in moodle

Priority LOW 39CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. The "delete badge alignment" functionality did not include the necessary token check to prevent a CSRF risk.

Why it matters now

EPSS 0.00604 49th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.11.5, 3.10.8, 3.9.11

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodlemoodle 3.11.5, moodle 3.10.9 and moodle 3.9.12—No fix listedCNA
—moodle/moodle (Packagist)3.11 to before 3.11.53.11.5Patch availableGHSA-xpfv-89vg-r562
—moodle/moodle (Packagist)3.10 to before 3.10.83.10.8Patch availableGHSA-xpfv-89vg-r562
—moodle/moodle (Packagist)3.9 to before 3.9.113.9.11Patch availableGHSA-xpfv-89vg-r562
  • moodle Vendor— Affected moodle 3.11.5, moodle 3.10.9 and moodle 3.9.12 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.5 Fixed in 3.11.5 Patch available GHSA-xpfv-89vg-r562
  • moodle/moodle (Packagist) Vendor— Affected 3.10 to before 3.10.8 Fixed in 3.10.8 Patch available GHSA-xpfv-89vg-r562
  • moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.11 Fixed in 3.9.11 Patch available GHSA-xpfv-89vg-r562

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*up to 3.8.9; 3.9.0 to before 3.9.12; 3.10.0 to before 3.10.9; 3.11.0 to before 3.11.5VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 3.8.9; 3.9.0 to before 3.9.12; 3.10.0 to before 3.10.9; 3.11.0 to before 3.11.5 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-xpfv-89vg-r562 moodle/moodle (Packagist) Fixed in 3.11.5 Advisory →
  • Fix · GHSA-xpfv-89vg-r562 moodle/moodle (Packagist) Fixed in 3.10.8 Advisory →
  • Fix · GHSA-xpfv-89vg-r562 moodle/moodle (Packagist) Fixed in 3.9.11 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0335
  2. 2026-10-03 Alias added: GHSA-xpfv-89vg-r562

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources