Cross-site Scripting (XSS) - DOM in tastyigniter/tastyigniter
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site Scripting (XSS) - DOM in GitHub repository tastyigniter/tastyigniter prior to 3.3.0.
Why it matters now
EPSS 0.00719 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tastyigniter/tastyigniter (tastyigniter): 3.3.0tastyigniter/tastyigniter (Packagist): 3.3.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tastyigniter | tastyigniter/tastyigniter | before 3.3.0 | 3.3.0 | Patch available | CNA |
| — | tastyigniter/tastyigniter (Packagist) | before 3.3.0 | 3.3.0 | Patch available | GHSA-cjw5-f2x5-r4q5 |
- tastyigniter/tastyigniter Vendortastyigniter Affected before 3.3.0 Fixed in 3.3.0 Patch available CNA
- tastyigniter/tastyigniter (Packagist) Vendor— Affected before 3.3.0 Fixed in 3.3.0 Patch available GHSA-cjw5-f2x5-r4q5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:tastyigniter:tastyigniter:*:*:*:*:*:*:*:* | before 3.3.0 | Vulnerable | tastyigniter |
- cpe:2.3:a:tastyigniter:tastyigniter:*:*:*:*:*:*:*:* Versions before 3.3.0 Vulnerable ·tastyigniter
Remediation
- Fix · CNA tastyigniter/tastyigniter (tastyigniter) Fixed in 3.3.0
- Fix · GHSA-cjw5-f2x5-r4q5 tastyigniter/tastyigniter (Packagist) Fixed in 3.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0602
- 2026-10-03 Alias added: GHSA-cjw5-f2x5-r4q5
References
More Tastyigniter vulnerabilities
- TI-2025-37990 Cross-Site Scripting (XSS) vulnerability exists in TastyIgniter 3.7.7, affecting the… CVSS 3.1HIGH 8.8
- TI-2024-29865 TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the invoice()… CVSS 3.1HIGH 8.1
- TI-2021-16270 TastyIgniter 3.0.7 allows XSS via /account, /reservation, /admin/dashboard, and /admin/system_logs. CVSS 3.1MEDIUM 5.4
- TI-2024-29866 TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders… CVSS 3.1MEDIUM 6.5
- TI-2022-07469 A Cross-Site Scripting (XSS) vulnerability exists within the 3.2.2 version of… CVSS 3.1MEDIUM 5.4
- TI-2022-17928 TastyIgniter v3.5.0 was discovered to contain a cross-site scripting (XSS) vulnerability… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-0602 · CVE Program
- CVE-2022-0602 · NVD
- FIRST EPSS
- GHSA-cjw5-f2x5-r4q5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences