TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the invoice()…
Priority LOW 39CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the invoice() function within Orders.php which allows unauthorized users to access and generate invoices due to missing permission checks.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00737 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tastyigniter/tastyigniter (Packagist): 4.0.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | tastyigniter/tastyigniter (Packagist) | before 4.0.0 | 4.0.0 | Patch available | GHSA-gg2f-r4jh-vpmh |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- tastyigniter/tastyigniter (Packagist) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-gg2f-r4jh-vpmh
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:tastyigniter:tastyigniter:3.7.6:*:*:*:*:*:*:* | 3.7.6 | Vulnerable | tastyigniter |
- cpe:2.3:a:tastyigniter:tastyigniter:3.7.6:*:*:*:*:*:*:* Versions 3.7.6 Vulnerable ·tastyigniter
Remediation
- Fix · GHSA-gg2f-r4jh-vpmh tastyigniter/tastyigniter (Packagist) Fixed in 4.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-44313
- 2026-10-03 Alias added: GHSA-gg2f-r4jh-vpmh
References
More Tastyigniter vulnerabilities
- TI-2025-37990 Cross-Site Scripting (XSS) vulnerability exists in TastyIgniter 3.7.7, affecting the… CVSS 3.1HIGH 8.8
- TI-2021-16270 TastyIgniter 3.0.7 allows XSS via /account, /reservation, /admin/dashboard, and /admin/system_logs. CVSS 3.1MEDIUM 5.4
- TI-2024-29866 TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders… CVSS 3.1MEDIUM 6.5
- TI-2022-07469 A Cross-Site Scripting (XSS) vulnerability exists within the 3.2.2 version of… CVSS 3.1MEDIUM 5.4
- TI-2022-00519 Cross-site Scripting (XSS) - DOM in tastyigniter/tastyigniter CVSS 3.1MEDIUM 5.4
- TI-2022-17928 TastyIgniter v3.5.0 was discovered to contain a cross-site scripting (XSS) vulnerability… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-44313 · CVE Program
- CVE-2024-44313 · NVD
- FIRST EPSS
- GHSA-gg2f-r4jh-vpmh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences