TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to update order statuses. The issue occurs in the index_onUpdateStatus() function within Orders.php, which fails to verify if the user has permission to modify an order's status. This flaw can be exploited remotely, leading to unauthorized order manipulation.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | tastyigniter/tastyigniter (Packagist) | before 4.0.0 | 4.0.0 | Patch available | GHSA-w5h7-mw56-4v7x |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- tastyigniter/tastyigniter (Packagist) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-w5h7-mw56-4v7x
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:tastyigniter:tastyigniter:3.7.6:*:*:*:*:*:*:* | 3.7.6 | Vulnerable | tastyigniter |
- cpe:2.3:a:tastyigniter:tastyigniter:3.7.6:*:*:*:*:*:*:* Versions 3.7.6 Vulnerable ·tastyigniter
Remediation
- Fix · GHSA-w5h7-mw56-4v7x tastyigniter/tastyigniter (Packagist) Fixed in 4.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-44314
- 2026-10-03 Alias added: GHSA-w5h7-mw56-4v7x
References
More Tastyigniter vulnerabilities
- TI-2025-37990 Cross-Site Scripting (XSS) vulnerability exists in TastyIgniter 3.7.7, affecting the… CVSS 3.1HIGH 8.8
- TI-2024-29865 TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the invoice()… CVSS 3.1HIGH 8.1
- TI-2021-16270 TastyIgniter 3.0.7 allows XSS via /account, /reservation, /admin/dashboard, and /admin/system_logs. CVSS 3.1MEDIUM 5.4
- TI-2022-07469 A Cross-Site Scripting (XSS) vulnerability exists within the 3.2.2 version of… CVSS 3.1MEDIUM 5.4
- TI-2022-00519 Cross-site Scripting (XSS) - DOM in tastyigniter/tastyigniter CVSS 3.1MEDIUM 5.4
- TI-2022-17928 TastyIgniter v3.5.0 was discovered to contain a cross-site scripting (XSS) vulnerability… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-44314 · CVE Program
- CVE-2024-44314 · NVD
- FIRST EPSS
- GHSA-w5h7-mw56-4v7x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences