Amelia < 1.0.46 - Arbitrary Customer Deletion via CSRF
Priority LOW 20CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
The Amelia WordPress plugin before 1.0.47 does not have CSRF check in place when deleting customers, which could allow attackers to make a logged in admin delete arbitrary customers via a CSRF attack
Why it matters now
EPSS 0.00435 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Amelia – Events & Appointments Booking Calendar (Unknown): 1.0.47
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Amelia – Events & Appointments Booking Calendar | 1.0.47 to before 1.0.47 | 1.0.47 | Patch available | CNA |
- Amelia – Events & Appointments Booking Calendar VendorUnknown Affected 1.0.47 to before 1.0.47 Fixed in 1.0.47 Patch available CNA
Remediation
- Fix · CNA Amelia – Events & Appointments Booking Calendar (Unknown) Fixed in 1.0.47
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Amelia – Events & Appointments Booking Calendar 1.0.47
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2022-00601 Amelia < 1.0.46 - Manager+ RCEPriority MEDIUM 41
- TI-2022-00544 Amelia < 1.0.46 - Reflected Cross-Site ScriptingPriority LOW 29
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0616
- 2026-10-03 Alias added: GHSA-chqh-f22c-h6qc
References
More TMS Amelia vulnerabilities
- TI-2024-14885 WordPress Amelia plugin <= 1.0.98 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-00601 Amelia < 1.0.46 - Manager+ RCE CVSS 3.1HIGH 8.8
- TI-2023-13807 WordPress Amelia Plugin <= 1.0.75 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-27765 WordPress Amelia Plugin <= 1.0.85 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2023-06220 Cross-site scripting in ameliabooking Booking for Appointments and Events Calendar… CVSS 3.1MEDIUM 6.4
- TI-2022-00544 Amelia < 1.0.46 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-0616 · CVE Program
- CVE-2022-0616 · NVD
- FIRST EPSS
- GHSA-chqh-f22c-h6qc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences