Amelia < 1.0.46 - Reflected Cross-Site Scripting
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Amelia WordPress plugin before 1.0.47 does not sanitize and escape the code parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting.
Why it matters now
EPSS 0.008 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Amelia – Events & Appointments Booking Calendar (Unknown): 1.0.47
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Amelia – Events & Appointments Booking Calendar | 1.0.47 to before 1.0.47 | 1.0.47 | Patch available | CNA |
- Amelia – Events & Appointments Booking Calendar VendorUnknown Affected 1.0.47 to before 1.0.47 Fixed in 1.0.47 Patch available CNA
Remediation
- Fix · CNA Amelia – Events & Appointments Booking Calendar (Unknown) Fixed in 1.0.47
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Amelia – Events & Appointments Booking Calendar 1.0.47
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2022-00601 Amelia < 1.0.46 - Manager+ RCEPriority MEDIUM 41
- TI-2022-00533 Amelia < 1.0.46 - Arbitrary Customer Deletion via CSRFPriority LOW 20
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0627
- 2026-10-03 Alias added: GHSA-pq9j-7g2h-8845
References
More TMS Amelia vulnerabilities
- TI-2024-14885 WordPress Amelia plugin <= 1.0.98 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-00601 Amelia < 1.0.46 - Manager+ RCE CVSS 3.1HIGH 8.8
- TI-2023-13807 WordPress Amelia Plugin <= 1.0.75 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-27765 WordPress Amelia Plugin <= 1.0.85 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2023-06220 Cross-site scripting in ameliabooking Booking for Appointments and Events Calendar… CVSS 3.1MEDIUM 6.4
- TI-2023-12509 Cross-site scripting in TMS Appointment and Event Booking Calendar for WordPress - Amelia CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-0627 · CVE Program
- CVE-2022-0627 · NVD
- FIRST EPSS
- GHSA-pq9j-7g2h-8845 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences