Improper authentication in moodle
Priority LOW 21CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.
Why it matters now
EPSS 0.00557 46th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.11.6, 3.10.10, 3.9.13
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | moodle 3.11.6, moodle 3.10.10, moodle 3.9.13 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.11.0 to before 3.11.6 | 3.11.6 | Patch available | GHSA-6q9g-3vfq-q2qj |
| — | moodle/moodle (Packagist) | 3.10.0 to before 3.10.10 | 3.10.10 | Patch available | GHSA-6q9g-3vfq-q2qj |
| — | moodle/moodle (Packagist) | 3.9 to before 3.9.13 | 3.9.13 | Patch available | GHSA-6q9g-3vfq-q2qj |
- moodle Vendor— Affected moodle 3.11.6, moodle 3.10.10, moodle 3.9.13 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.11.0 to before 3.11.6 Fixed in 3.11.6 Patch available GHSA-6q9g-3vfq-q2qj
- moodle/moodle (Packagist) Vendor— Affected 3.10.0 to before 3.10.10 Fixed in 3.10.10 Patch available GHSA-6q9g-3vfq-q2qj
- moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.13 Fixed in 3.9.13 Patch available GHSA-6q9g-3vfq-q2qj
Remediation
- Fix · GHSA-6q9g-3vfq-q2qj moodle/moodle (Packagist) Fixed in 3.11.6 Advisory →
- Fix · GHSA-6q9g-3vfq-q2qj moodle/moodle (Packagist) Fixed in 3.10.10 Advisory →
- Fix · GHSA-6q9g-3vfq-q2qj moodle/moodle (Packagist) Fixed in 3.9.13 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0985
- 2026-10-03 Alias added: GHSA-6q9g-3vfq-q2qj
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2022-0985 · CVE Program
- CVE-2022-0985 · NVD
- FIRST EPSS
- GHSA-6q9g-3vfq-q2qj · GitHub Advisory Database · CC BY 4.0
- CVE-2022-0985 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences