Read the docs
TI-2022-01136 Aliases CVE-2022-1250GHSA-xc5f-4vv8-gxfp

LifterLMS PayPal < 1.4.0 - Reflected Cross-Site Scripting

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The LifterLMS PayPal WordPress plugin before 1.4.0 does not sanitise and escape some parameters from the payment confirmation page before outputting them back in the page, leading to a Reflected Cross-Site Scripting issue

Why it matters now

EPSS 0.0095 61st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed LifterLMS Paypal (Unknown): 1.4.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownLifterLMS Paypal1.4.0 to before 1.4.01.4.0Patch availableCNA
  • LifterLMS Paypal VendorUnknown Affected 1.4.0 to before 1.4.0 Fixed in 1.4.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:lifterlms:lifterlms:*:*:*:*:*:wordpress:*:*before 1.4.0Vulnerablechrisbadgett
  • cpe:2.3:a:lifterlms:lifterlms:*:*:*:*:*:wordpress:*:* Versions before 1.4.0 Vulnerable ·chrisbadgett

Remediation

  • Fix · CNA LifterLMS Paypal (Unknown) Fixed in 1.4.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1250
  2. 2026-10-03 Alias added: GHSA-xc5f-4vv8-gxfp

References

  • TI-2024-12660 LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes < 8.0.1 - Reflected XSS CVSS 3.1MEDIUM 6.1
  • TI-2019-11948 An issue was discovered in the LifterLMS plugin through 3.34.5 for WordPress. CVSS 3.1CRITICAL 9.8
  • TI-2020-04909 LifterLMS Wordpress plugin version below 3.37.15 is vulnerable to arbitrary file write leading to remote code execution CVSS 3.1CRITICAL 9.8
  • TI-2025-32767 WordPress LifterLMS plugin <= 8.0.6 - SQL Injection Vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2024-04416 LifterLMS – WordPress LMS Plugin for eLearning <= 7.6.2 - Authenticated (Contributor+) SQL Injection via Shortcode CVSS 3.1HIGH 8.8
  • TI-2024-20735 WordPress LifterLMS plugin <= 7.5.0 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
See all 13 →

Sources