Discy < 5.2 - Settings Update via CSRF
Priority LOW 23CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
The Discy WordPress theme before 5.2 lacks CSRF checks in some AJAX actions, allowing an attacker to make a logged in admin change arbitrary 's settings including payment methods via a CSRF attack
Why it matters now
EPSS 0.01316 70th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Discy (Unknown): 5.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Discy | 5.2 to before 5.2 | 5.2 | Patch available | CNA |
- Discy VendorUnknown Affected 5.2 to before 5.2 Fixed in 5.2 Patch available CNA
Remediation
- Fix · CNA Discy (Unknown) Fixed in 5.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Discy 5.2
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-01303 Discy < 5.2 - Restore Default Settings via CSRFPriority LOW 30
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1421
- 2026-10-03 Alias added: GHSA-mpq8-cm6q-wpq8
References
More 2code Discy vulnerabilities
- TI-2022-01303 Discy < 5.2 - Restore Default Settings via CSRF CVSS 3.1MEDIUM 6.5
- TI-2022-01205 Discy < 5.0 - Subscriber+ Broken Access Control to change settings CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-1421 · CVE Program
- CVE-2022-1421 · NVD
- FIRST EPSS
- GHSA-mpq8-cm6q-wpq8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences