In affected versions of Octopus Deploy it is possible to unmask sensitive variables by using variable preview.
Priority LOW 25CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
In affected versions of Octopus Deploy it is possible to unmask sensitive variables by using variable preview.
Why it matters now
EPSS 0.00563 47th percentileScored 2026-11-07
Fix Fixed Octopus Server (Octopus Deploy): 2022.1.3009, 2022.2.7244, 2022.3.4953
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 2019.7.3 and later; before 2022.1.3009; 2022.2.6729 and later; before 2022.2.7244; 2022.3.348 and later; before 2022.3.4953 | 2022.1.3009, 2022.2.7244, 2022.3.4953 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 2019.7.3 and later; before 2022.1.3009; 2022.2.6729 and later; before 2022.2.7244; 2022.3.348 and later; before 2022.3.4953 Fixed in 2022.1.3009, 2022.2.7244, 2022.3.4953 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* | 2019.1.0 – 2019.7.3; 2020.1.0 – 2020.6.5449; 2021.1.6959 – 2021.3.13021; 2022.1.0 to before 2022.1.3009; 2022.2.6729 to before 2022.2.7244; 2022.3.348 to before 2022.3.4953 | Vulnerable | Octopus Deploy |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Linux |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* Versions 2019.1.0 – 2019.7.3; 2020.1.0 – 2020.6.5449; 2021.1.6959 – 2021.3.13021; 2022.1.0 to before 2022.1.3009; 2022.2.6729 to before 2022.2.7244; 2022.3.348 to before 2022.3.4953 Vulnerable ·Octopus Deploy
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2022.1.3009, 2022.2.7244, 2022.3.4953
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1901
- 2026-10-03 Alias added: GHSA-rrhg-rvvx-6575
References
More Octopus Deploy Octopus Server vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
- TI-2022-03678 In affected versions of Octopus Deploy it is possible for a user to introduce code via offline package creation CVSS 3.1HIGH 8.8
Sources
- CVE-2022-1901 · CVE Program
- CVE-2022-1901 · NVD
- FIRST EPSS
- GHSA-rrhg-rvvx-6575 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences