Easy Pricing Tables < 3.2.1 - Reflected Cross-Site-Scripting
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Pricing Tables WordPress Plugin WordPress plugin before 3.2.1 does not sanitise and escape parameter before outputting it back in a page available to any user (both authenticated and unauthenticated) when a specific setting is enabled, leading to a Reflected Cross-Site Scripting
Why it matters now
EPSS 0.0148 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Pricing Tables WordPress Plugin – Easy Pricing Tables (Unknown): 3.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Pricing Tables WordPress Plugin – Easy Pricing Tables | 3.2.1 to before 3.2.1 | 3.2.1 | Patch available | CNA |
- Pricing Tables WordPress Plugin – Easy Pricing Tables VendorUnknown Affected 3.2.1 to before 3.2.1 Fixed in 3.2.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fatcatapps:easy_pricing_tables:*:*:*:*:*:wordpress:*:* | before 3.2.1 | Vulnerable | fatcatapps |
- cpe:2.3:a:fatcatapps:easy_pricing_tables:*:*:*:*:*:wordpress:*:* Versions before 3.2.1 Vulnerable ·fatcatapps
Remediation
- Fix · CNA Pricing Tables WordPress Plugin – Easy Pricing Tables (Unknown) Fixed in 3.2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1904
- 2026-10-03 Alias added: GHSA-5gj7-9vg9-w5rc
References
More fatcatapps Easy Pricing Tables vulnerabilities
- TI-2021-07376 Easy Pricing Tables < 3.1.3 - Arbitrary Post Removal via CSRF CVSS 3.1MEDIUM 6.5
- TI-2024-07717 Cross-site scripting in fatcatapps Pricing Table WordPress Plugin – Easy Pricing Tables CVSS 3.1MEDIUM 6.4
- TI-2021-14959 WordPress Easy Pricing Tables plugin <= 3.1.2 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 4.8
Sources
- CVE-2022-1904 · CVE Program
- CVE-2022-1904 · NVD
- FIRST EPSS
- GHSA-5gj7-9vg9-w5rc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences