Sensei LMS < 4.5.2 - Arbitrary Private Message Sending via IDOR
Priority LOW 22CWE-639Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-639.
Summary
The Sensei LMS WordPress plugin before 4.5.2 does not ensure that the sender of a private message is either the teacher or the original sender, allowing any authenticated user to send messages to arbitrary private conversation via a IDOR attack. Note: Attackers are not able to see responses/messages between the teacher and student
Why it matters now
EPSS 0.00811 57th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Sensei LMS – Online Courses, Quizzes, & Learning (Unknown): 4.5.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Sensei LMS – Online Courses, Quizzes, & Learning | 4.5.2 to before 4.5.2 | 4.5.2 | Patch available | CNA |
- Sensei LMS – Online Courses, Quizzes, & Learning VendorUnknown Affected 4.5.2 to before 4.5.2 Fixed in 4.5.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:automattic:sensei_lms:*:*:*:*:*:wordpress:*:* | before 4.5.2 | Vulnerable | Automattic |
- cpe:2.3:a:automattic:sensei_lms:*:*:*:*:*:wordpress:*:* Versions before 4.5.2 Vulnerable ·Automattic
Remediation
- Fix · CNA Sensei LMS – Online Courses, Quizzes, & Learning (Unknown) Fixed in 4.5.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2080
- 2026-10-03 Alias added: GHSA-35xw-38xf-5f44
References
More Automattic Sensei Lms vulnerabilities
- TI-2024-07219 Sensei LMS < 4.24.2 - Unauthenticated Email Template Leak CVSS 3.1HIGH 7.5
- TI-2024-07423 Sensei LMS < 4.20.0 - Teacher+ Users Email Address Disclosure CVSS 3.1MEDIUM 4.3
- TI-2025-00383 Sensei LMS < 4.24.4 - Unauthenticated sensei_email/sensei_message Disclosure CVSS 3.1MEDIUM 5.3
- TI-2023-27779 WordPress Sensei LMS Plugin <= 4.17.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2022-01885 Sensei LMS < 4.5.0 - Unauthenticated Private Messages Disclosure via Rest API CVSS 3.1MEDIUM 5.3
Sources
- CVE-2022-2080 · CVE Program
- CVE-2022-2080 · NVD
- FIRST EPSS
- GHSA-35xw-38xf-5f44 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences