In affected versions of Octopus Deploy it is possible for a user to view Tagsets without…
Priority LOW 21Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
In affected versions of Octopus Deploy it is possible for a user to view Tagsets without being explicitly assigned permissions to view these items
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00496 42nd percentileScored 2026-11-07
Fix Fixed Octopus Server (Octopus Deploy): 2022.3.11098, 2022.4.8463, 2023.1.9672
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 2019.1.0 and later; before 2022.3.11098; 2022.4.791 and later; before 2022.4.8463; 2023.1.4189 and later; before 2023.1.9672 | 2022.3.11098, 2022.4.8463, 2023.1.9672 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 2019.1.0 and later; before 2022.3.11098; 2022.4.791 and later; before 2022.4.8463; 2023.1.4189 and later; before 2023.1.9672 Fixed in 2022.3.11098, 2022.4.8463, 2023.1.9672 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* | 2019.1.0 to before 2022.3.11098; 2022.4.791 to before 2022.4.8463; 2023.1.4189 to before 2023.1.9672 | Vulnerable | Octopus Deploy |
| cpe:2.3:a:octopus:octopus_server:2023.2.2028:*:*:*:*:*:*:* | 2023.2.2028 | Vulnerable | Octopus Deploy |
- cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* Versions 2019.1.0 to before 2022.3.11098; 2022.4.791 to before 2022.4.8463; 2023.1.4189 to before 2023.1.9672 Vulnerable ·Octopus Deploy
- cpe:2.3:a:octopus:octopus_server:2023.2.2028:*:*:*:*:*:*:* Versions 2023.2.2028 Vulnerable ·Octopus Deploy
Remediation
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2022.3.11098, 2022.4.8463, 2023.1.9672
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Octopus Server 2022.3.11098, 2022.4.8463 and 2 more versions
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-02084 Improper access control in Octopus ServerPriority LOW 20
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2258
- 2026-10-03 Alias added: GHSA-79mw-p7qm-h4wp
References
More Octopus Deploy Octopus Server vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
- TI-2022-03678 In affected versions of Octopus Deploy it is possible for a user to introduce code via offline package creation CVSS 3.1HIGH 8.8
Sources
- CVE-2022-2258 · CVE Program
- CVE-2022-2258 · NVD
- FIRST EPSS
- GHSA-79mw-p7qm-h4wp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences