WP All Import < 3.6.8 - Admin+ Arbitrary File Upload
Priority LOW 35CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-434.
Summary
The Import any XML or CSV File to WordPress plugin before 3.6.8 accepts all zip files and automatically extracts the zip file without validating the extracted file type. Allowing high privilege users such as admin to upload an arbitrary file like PHP, leading to RCE
Why it matters now
EPSS 0.0142 72nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Import any XML or CSV File to WordPress (Unknown): 3.6.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Import any XML or CSV File to WordPress | 3.6.8 to before 3.6.8 | 3.6.8 | Patch available | CNA |
- Import any XML or CSV File to WordPress VendorUnknown Affected 3.6.8 to before 3.6.8 Fixed in 3.6.8 Patch available CNA
Remediation
- Fix · CNA Import any XML or CSV File to WordPress (Unknown) Fixed in 3.6.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2268
- 2026-10-03 Alias added: GHSA-ph58-3qm4-jpww
References
More Soflyy Wp All Import vulnerabilities
- TI-2022-03156 WP All Import < 3.6.9 - Admin+ Arbitrary File Upload to RCE CVSS 3.1HIGH 7.2
- TI-2022-02509 WP All Import < 3.6.9 - Admin+ Directory traversal via file upload CVSS 3.1HIGH 7.2
- TI-2015-07707 The wp-all-import plugin before 3.2.5 for WordPress has blind SQL injection. CVSS 3.0CRITICAL 9.8
- TI-2022-16725 WordPress Import any XML or CSV File to WordPress plugin <= 3.6.7 - Authenticated Arbitrary Code Execution vulnerability CVSS 3.1CRITICAL 9.1
- TI-2015-07708 The wp-all-import plugin before 3.2.4 for WordPress has no prevention of unauthenticated requests to adminInit. CVSS 3.0HIGH 7.5
- TI-2024-08966 WP All Import Pro <= 4.9.7 - Authenticated (Administrator+) PHP Object Injection via Import File CVSS 3.1HIGH 7.2
Sources
- CVE-2022-2268 · CVE Program
- CVE-2022-2268 · NVD
- FIRST EPSS
- GHSA-ph58-3qm4-jpww · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences