WP Popup Builder < 1.2.9 - Reflected Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Popup Builder WordPress plugin before 1.2.9 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Popup Builder – Popup Forms , Marketing PoPuP & Newsletter | 1.2.9 to before 1.2.9 | 1.2.9 | Patch available | CNA |
- WP Popup Builder – Popup Forms , Marketing PoPuP & Newsletter VendorUnknown Affected 1.2.9 to before 1.2.9 Fixed in 1.2.9 Patch available CNA
Remediation
- Fix · CNA WP Popup Builder – Popup Forms , Marketing PoPuP & Newsletter (Unknown) Fixed in 1.2.9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
WP Popup Builder – Popup Forms , Marketing PoPuP & Newsletter 1.2.9
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2022-02220 WP Popup Builder < 1.3.0 - Subscriber+ Arbitrary Popup DeletionPriority MEDIUM 53
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2404
- 2026-10-03 Alias added: GHSA-j2hx-526f-q8h2
- 2026-10-31 EPSS moved to the 50th–90th percentile
- 2026-11-02 EPSS moved to the below the 50th percentile
- 2026-11-03 EPSS moved to the 50th–90th percentile
References
More themehunk Wp Popup Builder vulnerabilities
- TI-2024-08412 Code injection in themehunk WP Popup Builder – Popup Forms and Marketing Lead Generation CVSS 3.1CRITICAL 9.8
- TI-2022-02220 WP Popup Builder < 1.3.0 - Subscriber+ Arbitrary Popup Deletion CVSS 3.1MEDIUM 4.3
- TI-2025-39051 WordPress WP Popup Builder plugin <= 1.3.8 - Sensitive Data Exposure vulnerability CVSS 3.1MEDIUM 5.3
Sources
- CVE-2022-2404 · CVE Program
- CVE-2022-2404 · NVD
- FIRST EPSS
- GHSA-j2hx-526f-q8h2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences