Read the docs
TI-2024-08412 Aliases CVE-2024-9061GHSA-fvv3-x64f-px6p

Code injection in themehunk WP Popup Builder – Popup Forms and Marketing Lead Generation

Priority HIGH 80CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-94.

Summary

The The WP Popup Builder – Popup Forms and Marketing Lead Generation plugin for WordPress is vulnerable to arbitrary shortcode execution via the wp_ajax_nopriv_shortcode_Api_Add AJAX action in all versions up to, and including, 1.3.5. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. NOTE: This vulnerability was partially fixed in version 1.3.5 with a nonce check, which effectively prevented access to the affected function. However, version 1.3.6 incorporates the correct authorization check to prevent unauthorized access.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.52266 98th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
themehunkWP Popup Builder – Popup Forms and Marketing Lead Generationup to 1.3.5—No fix listedCNA
  • WP Popup Builder – Popup Forms and Marketing Lead Generation Vendorthemehunk Affected up to 1.3.5 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:themehunk:wp_popup_builder:*:*:*:*:*:wordpress:*:*before 1.3.6Vulnerablethemehunk
  • cpe:2.3:a:themehunk:wp_popup_builder:*:*:*:*:*:wordpress:*:* Versions before 1.3.6 Vulnerable ·themehunk

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-9061
  2. 2026-10-03 Alias added: GHSA-fvv3-x64f-px6p

References

  • TI-2022-02219 WP Popup Builder < 1.2.9 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2022-02220 WP Popup Builder < 1.3.0 - Subscriber+ Arbitrary Popup Deletion CVSS 3.1MEDIUM 4.3
  • TI-2025-39051 WordPress WP Popup Builder plugin <= 1.3.8 - Sensitive Data Exposure vulnerability CVSS 3.1MEDIUM 5.3

Sources