Server-side request forgery in Octopus Server
Priority LOW 25CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In affected versions of Octopus Deploy it is possible for a low privileged guest user to craft a request that allows enumeration/recon of an environment.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00299 22nd percentileScored 2026-11-07
Fix Fixed Octopus Server (Octopus Deploy): 2022.4.9997, 2023.1.10235, 2023.2.10545
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 2019.4.0 to before 2022.4.9997; 2023.1.0 to before 2023.1.10235; 2023.2.0 to before 2023.2.10545 | 2022.4.9997, 2023.1.10235, 2023.2.10545 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 2019.4.0 to before 2022.4.9997; 2023.1.0 to before 2023.1.10235; 2023.2.0 to before 2023.2.10545 Fixed in 2022.4.9997, 2023.1.10235, 2023.2.10545 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* | 2019.4.0 to before 2022.4.9997; 2023.1.4189 to before 2023.1.10235; 2023.2.2028 to before 2023.2.10545 | Vulnerable | Octopus Deploy |
- cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* Versions 2019.4.0 to before 2022.4.9997; 2023.1.4189 to before 2023.1.10235; 2023.2.2028 to before 2023.2.10545 Vulnerable ·Octopus Deploy
Remediation
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2022.4.9997, 2023.1.10235, 2023.2.10545
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Octopus Server 2022.4.9997, 2023.1.10235, 2023.2.10545
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-02167 In affected versions of Octopus Deploy it is possible for a low privileged guest user to…Priority LOW 25
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2416
- 2026-10-03 Alias added: GHSA-48r8-6rwx-4hc4
References
More Octopus Deploy Octopus Server vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
- TI-2022-03678 In affected versions of Octopus Deploy it is possible for a user to introduce code via offline package creation CVSS 3.1HIGH 8.8
Sources
- CVE-2022-2416 · CVE Program
- CVE-2022-2416 · NVD
- FIRST EPSS
- GHSA-48r8-6rwx-4hc4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences