Tutor LMS < 2.0.10 - Admin+ Stored Cross-Site Scripting
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Tutor LMS WordPress plugin before 2.0.10 does not escape some course parameters, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00729 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Tutor LMS – eLearning and online course solution (Unknown): 2.0.10
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Tutor LMS – eLearning and online course solution | 2.0.10 to before 2.0.10 | 2.0.10 | Patch available | CNA |
- Tutor LMS – eLearning and online course solution VendorUnknown Affected 2.0.10 to before 2.0.10 Fixed in 2.0.10 Patch available CNA
Remediation
- Fix · CNA Tutor LMS – eLearning and online course solution (Unknown) Fixed in 2.0.10
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2563
- 2026-10-03 Alias added: GHSA-8vp3-gv73-jccx
- 2026-10-14 EPSS moved to the 50th–90th percentile
References
More themeum Tutor Lms vulnerabilities
- TI-2024-09629 Tutor LMS <= 2.7.6 - Unauthenticated SQL Injection via rating_filter CVSS 3.1HIGH 7.5
- TI-2023-02936 Tutor LMS < 2.2.1 - Unauthenticated Access to Tutor LMS Lesson Resources via REST API CVSS 3.1HIGH 7.5
- TI-2023-00225 Tutor LMS < 2.0.10 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-04422 Tutor LMS < 2.3.0 - Subscriber+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
- TI-2024-05054 Authorization bypass in themeum Tutor LMS – eLearning and online course solution CVSS 3.1MEDIUM 4.3
- TI-2023-10976 WordPress Tutor LMS Plugin <= 2.1.10 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-2563 · CVE Program
- CVE-2022-2563 · NVD
- FIRST EPSS
- GHSA-8vp3-gv73-jccx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences