Tutor LMS < 2.3.0 - Subscriber+ Stored Cross-Site Scripting
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Tutor LMS WordPress plugin before 2.3.0 does not sanitise and escape some of its settings, which could allow users such as subscriber to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00471 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Tutor LMS (Unknown): 2.3.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Tutor LMS | before 2.3.0 | 2.3.0 | Patch available | CNA |
- Tutor LMS VendorUnknown Affected before 2.3.0 Fixed in 2.3.0 Patch available CNA
Remediation
- Fix · CNA Tutor LMS (Unknown) Fixed in 2.3.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4805
- 2026-10-03 Alias added: GHSA-fj34-c7pj-j8xq
References
More themeum Tutor Lms vulnerabilities
- TI-2024-09629 Tutor LMS <= 2.7.6 - Unauthenticated SQL Injection via rating_filter CVSS 3.1HIGH 7.5
- TI-2023-02936 Tutor LMS < 2.2.1 - Unauthenticated Access to Tutor LMS Lesson Resources via REST API CVSS 3.1HIGH 7.5
- TI-2023-00225 Tutor LMS < 2.0.10 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2022-02367 Tutor LMS < 2.0.10 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2024-05054 Authorization bypass in themeum Tutor LMS – eLearning and online course solution CVSS 3.1MEDIUM 4.3
- TI-2023-10976 WordPress Tutor LMS Plugin <= 2.1.10 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-4805 · CVE Program
- CVE-2023-4805 · NVD
- FIRST EPSS
- GHSA-fj34-c7pj-j8xq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences