Advanced Custom Fields 5.0-5.12.2 - Unauthenticated File Upload
Priority MEDIUM 41CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-434.
Summary
The Advanced Custom Fields WordPress plugin before 5.12.3, Advanced Custom Fields Pro WordPress plugin before 5.12.3 allows unauthenticated users to upload files allowed in a default WP configuration (so PHP is not possible) if there is a frontend form available. This vulnerability was introduced in the 5.0 rewrite and did not exist prior to that release.
Why it matters now
EPSS 0.01633 76th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Advanced Custom Fields (TODO): 5.12.3Advanced Custom Fields Pro (TODO): 5.12.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| TODO | Advanced Custom Fields | 5.0 and later; 5.12.3 to before 5.12.3 | 5.12.3 | Patch available | CNA |
| TODO | Advanced Custom Fields Pro | 5.0 and later; 5.12.3 to before 5.12.3 | 5.12.3 | Patch available | CNA |
- Advanced Custom Fields VendorTODO Affected 5.0 and later; 5.12.3 to before 5.12.3 Fixed in 5.12.3 Patch available CNA
- Advanced Custom Fields Pro VendorTODO Affected 5.0 and later; 5.12.3 to before 5.12.3 Fixed in 5.12.3 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:advancedcustomfields:advanced_custom_fields:*:*:*:*:*:wordpress:*:* | 5.0.0 to before 5.12.3 | Vulnerable | Advanced Custom Fields |
| cpe:2.3:a:advancedcustomfields:advanced_custom_fields:*:*:*:*:pro:wordpress:*:* | 5.0.0 to before 5.12.3 | Vulnerable | Advanced Custom Fields |
- cpe:2.3:a:advancedcustomfields:advanced_custom_fields:*:*:*:*:*:wordpress:*:* Versions 5.0.0 to before 5.12.3 Vulnerable ·Advanced Custom Fields
- cpe:2.3:a:advancedcustomfields:advanced_custom_fields:*:*:*:*:pro:wordpress:*:* Versions 5.0.0 to before 5.12.3 Vulnerable ·Advanced Custom Fields
Remediation
- Fix · CNA Advanced Custom Fields (TODO) Fixed in 5.12.3
- Fix · CNA Advanced Custom Fields Pro (TODO) Fixed in 5.12.3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2594
- 2026-10-03 Alias added: GHSA-m8hq-2c8m-w6cm
References
More Advanced Custom Fields vulnerabilities
- TI-2023-01131 Advanced Custom Fields - Contributor+ PHP Object Injection CVSS 3.1HIGH 8.8
- TI-2024-04251 Advanced Custom Fields < 6.3 - Contributor+ Custom Field Access CVSS 3.1HIGH 7.5
- TI-2024-08839 Secure Custom Fields < 6.3.6.3 - Admin+ Remote Code Execution CVSS 3.1MEDIUM 6.6
- TI-2023-14589 WordPress Advanced Custom Fields / Advanced Custom Fields PRO plugins <= 6.1.5 vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2022-19331 WordPress Advanced Custom Fields Plugin 3.1.1-6.0.2 is vulnerable to Sensitive Data Exposure CVSS 3.1HIGH 7.5
- TI-2021-04079 Missing authorization in Delicious Brains Advanced Custom Fields and Advanced Custom… CVSS 3.1HIGH 7.5
Sources
- CVE-2022-2594 · CVE Program
- CVE-2022-2594 · NVD
- FIRST EPSS
- GHSA-m8hq-2c8m-w6cm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences