Secure Custom Fields < 6.3.6.3 - Admin+ Remote Code Execution
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Secure Custom Fields WordPress plugin before 6.3.9, Secure Custom Fields WordPress plugin before 6.3.6.3, Advanced Custom Fields Pro WordPress plugin before 6.3.9 does not prevent users from running arbitrary functions through its setting import functionalities, which could allow high privilege users such as admin to run arbitrary PHP functions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Secure Custom Fields | 6.3.7 to before 6.3.9 | 6.3.9 | Patch available | CNA |
| Unknown | Secure Custom Fields | before 6.3.6.3 | 6.3.6.3 | Patch available | CNA |
| Unknown | Advanced Custom Fields Pro | before 6.3.9 | 6.3.9 | Patch available | CNA |
- Secure Custom Fields VendorUnknown Affected 6.3.7 to before 6.3.9 Fixed in 6.3.9 Patch available CNA
- Secure Custom Fields VendorUnknown Affected before 6.3.6.3 Fixed in 6.3.6.3 Patch available CNA
- Advanced Custom Fields Pro VendorUnknown Affected before 6.3.9 Fixed in 6.3.9 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:advancedcustomfields:advanced_custom_fields:*:*:*:*:free:wordpress:*:* | before 6.3.9 | Vulnerable | Advanced Custom Fields |
| cpe:2.3:a:advancedcustomfields:advanced_custom_fields:*:*:*:*:pro:wordpress:*:* | before 6.3.9 | Vulnerable | Advanced Custom Fields |
- cpe:2.3:a:advancedcustomfields:advanced_custom_fields:*:*:*:*:free:wordpress:*:* Versions before 6.3.9 Vulnerable ·Advanced Custom Fields
- cpe:2.3:a:advancedcustomfields:advanced_custom_fields:*:*:*:*:pro:wordpress:*:* Versions before 6.3.9 Vulnerable ·Advanced Custom Fields
Remediation
- Fix · CNA Secure Custom Fields (Unknown) Fixed in 6.3.9
- Fix · CNA Secure Custom Fields (Unknown) Fixed in 6.3.6.3
- Fix · CNA Advanced Custom Fields Pro (Unknown) Fixed in 6.3.9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9529
- 2026-10-03 Alias added: GHSA-w9hg-9q36-xm67
References
More Advanced Custom Fields vulnerabilities
- TI-2023-01131 Advanced Custom Fields - Contributor+ PHP Object Injection CVSS 3.1HIGH 8.8
- TI-2024-04251 Advanced Custom Fields < 6.3 - Contributor+ Custom Field Access CVSS 3.1HIGH 7.5
- TI-2023-14589 WordPress Advanced Custom Fields / Advanced Custom Fields PRO plugins <= 6.1.5 vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2022-02396 Advanced Custom Fields 5.0-5.12.2 - Unauthenticated File Upload CVSS 3.1HIGH 8.8
- TI-2022-19331 WordPress Advanced Custom Fields Plugin 3.1.1-6.0.2 is vulnerable to Sensitive Data Exposure CVSS 3.1HIGH 7.5
- TI-2021-04079 Missing authorization in Delicious Brains Advanced Custom Fields and Advanced Custom… CVSS 3.1HIGH 7.5
Sources
- CVE-2024-9529 · CVE Program
- CVE-2024-9529 · NVD
- FIRST EPSS
- GHSA-w9hg-9q36-xm67 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences