In affected versions of Octopus Server it was identified that when a sensitive value is a…
Priority LOW 31CWE-359Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-359.
Summary
In affected versions of Octopus Server it was identified that when a sensitive value is a substring of another value, sensitive value masking will only partially work.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00565 47th percentileScored 2026-11-07
Fix Fixed Octopus Server (Octopus Deploy): 2022.1.3134, 2022.2.7934, 2022.3.10586
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 3.16.4 and later; before 2022.1.3134; 2022.2.6729 and later; before 2022.2.7934; 2022.3.348 and later; before 2022.3.10586 | 2022.1.3134, 2022.2.7934, 2022.3.10586 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 3.16.4 and later; before 2022.1.3134; 2022.2.6729 and later; before 2022.2.7934; 2022.3.348 and later; before 2022.3.10586 Fixed in 2022.1.3134, 2022.2.7934, 2022.3.10586 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* | 3.16.4 to before 2022.1.3154; 2022.2.6729 to before 2022.2.7934; 2022.3.348 to before 2022.3.10586 | Vulnerable | Octopus Deploy |
- cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* Versions 3.16.4 to before 2022.1.3154; 2022.2.6729 to before 2022.2.7934; 2022.3.348 to before 2022.3.10586 Vulnerable ·Octopus Deploy
Remediation
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2022.1.3134, 2022.2.7934, 2022.3.10586
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2720
- 2026-10-03 Alias added: GHSA-hq39-62g2-phr4
References
More Octopus Deploy Octopus Server vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
- TI-2022-03678 In affected versions of Octopus Deploy it is possible for a user to introduce code via offline package creation CVSS 3.1HIGH 8.8
Sources
- CVE-2022-2720 · CVE Program
- CVE-2022-2720 · NVD
- FIRST EPSS
- GHSA-hq39-62g2-phr4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences