In affected versions of Octopus Server it was identified that a session cookie could be used as the CSRF token
Priority LOW 24CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
In affected versions of Octopus Server it was identified that a session cookie could be used as the CSRF token
Why it matters now
EPSS 0.00258 17th percentileScored 2026-11-07
Fix Fixed Octopus Server (Octopus Deploy): 2022.1.3154, 2022.2.7897, 2022.3.10586
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 3.12.0 and later; before 2022.1.3154; 2022.2.6729 and later; before 2022.2.7897; 2022.3.348 and later; before 2022.3.10586 | 2022.1.3154, 2022.2.7897, 2022.3.10586 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 3.12.0 and later; before 2022.1.3154; 2022.2.6729 and later; before 2022.2.7897; 2022.3.348 and later; before 2022.3.10586 Fixed in 2022.1.3154, 2022.2.7897, 2022.3.10586 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* | 3.12.0 to before 2022.1.3154; 2022.2.6729 to before 2022.2.7897; 2022.3.348 to before 2022.3.10586 | Vulnerable | Octopus Deploy |
- cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* Versions 3.12.0 to before 2022.1.3154; 2022.2.6729 to before 2022.2.7897; 2022.3.348 to before 2022.3.10586 Vulnerable ·Octopus Deploy
Remediation
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2022.1.3154, 2022.2.7897, 2022.3.10586
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Octopus Server 2022.1.3154, 2022.2.7897 and 2 more versions
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-02578 Broken or risky cryptographic algorithm in Octopus ServerPriority LOW 23
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2783
- 2026-10-03 Alias added: GHSA-qxv6-wcr6-hh88
References
More Octopus Deploy Octopus Server vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
- TI-2022-03678 In affected versions of Octopus Deploy it is possible for a user to introduce code via offline package creation CVSS 3.1HIGH 8.8
Sources
- CVE-2022-2783 · CVE Program
- CVE-2022-2783 · NVD
- FIRST EPSS
- GHSA-qxv6-wcr6-hh88 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences