Read the docs
TI-2022-02757 Aliases CVE-2022-2986GHSA-xjr3-fwp9-9g96

Enabling and disabling installed H5P libraries did not include the necessary token to prevent a CSRF risk.

Priority LOW 38CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

Enabling and disabling installed H5P libraries did not include the necessary token to prevent a CSRF risk.

Why it matters now

EPSS 0.00467 40th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.11.9, 4.0.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodlemoodle 4.0.3 and moodle 3.11.9—No fix listedCNA
—moodle/moodle (Packagist)3.11 to before 3.11.93.11.9Patch availableGHSA-xjr3-fwp9-9g96
—moodle/moodle (Packagist)4.0 to before 4.0.34.0.3Patch availableGHSA-xjr3-fwp9-9g96
  • moodle Vendor— Affected moodle 4.0.3 and moodle 3.11.9 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.9 Fixed in 3.11.9 Patch available GHSA-xjr3-fwp9-9g96
  • moodle/moodle (Packagist) Vendor— Affected 4.0 to before 4.0.3 Fixed in 4.0.3 Patch available GHSA-xjr3-fwp9-9g96

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.11.0 to before 3.11.9; 4.0.0 to before 4.0.3VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.11.0 to before 3.11.9; 4.0.0 to before 4.0.3 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-xjr3-fwp9-9g96 moodle/moodle (Packagist) Fixed in 3.11.9 Advisory →
  • Fix · GHSA-xjr3-fwp9-9g96 moodle/moodle (Packagist) Fixed in 4.0.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-2986
  2. 2026-10-03 Alias added: GHSA-xjr3-fwp9-9g96

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources