Read the docs
TI-2022-02949 Aliases CVE-2022-3194GHSA-5g8x-4pjj-p6fm

Dokan < 3.6.4 - Vendor Stored Cross-Site Scripting

Priority MEDIUM 58CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Dokan WordPress plugin before 3.6.4 allows vendors to inject arbitrary javascript in product reviews, which may allow them to run stored XSS attacks against other users like site administrators.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00491 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Dokan (Unknown): 3.6.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownDokanbefore 3.6.43.6.4Patch availableCNA
  • Dokan VendorUnknown Affected before 3.6.4 Fixed in 3.6.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:dokan:dokan:*:*:*:*:lite:wordpress:*:*before 3.6.4VulnerableDokan, Inc.
  • cpe:2.3:a:dokan:dokan:*:*:*:*:lite:wordpress:*:* Versions before 3.6.4 Vulnerable ·Dokan, Inc.

Remediation

  • Fix · CNA Dokan (Unknown) Fixed in 3.6.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-3194
  2. 2026-10-03 Alias added: GHSA-5g8x-4pjj-p6fm

References

  • TI-2022-03590 Dokan < 3.7.6 - Unauthenticated SQLi CVSS 3.1CRITICAL 9.8
  • TI-2024-03660 Dokan Pro <= 3.10.3 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 10.0
  • TI-2023-17212 WordPress Dokan Plugin <= 3.7.19 is vulnerable to PHP Object Injection CVSS 3.1HIGH 8.8
  • TI-2023-11662 WordPress Dokan Plugin <= 3.7.12 is vulnerable to SQL Injection CVSS 3.1HIGH 8.1
  • TI-2020-18917 Dokan <= 3.0.8 - Cross-Site Request Forgery Bypass CVSS 3.1MEDIUM 4.3

Sources