Read the docs
TI-2022-03590 Aliases CVE-2022-3915GHSA-2776-fr3j-r98m

Dokan < 3.7.6 - Unauthenticated SQLi

Priority HIGH 82CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.

Summary

The Dokan WordPress plugin before 3.7.6 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by unauthenticated users

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01134 66th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Dokan (Unknown): 3.7.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownDokan2.6.8 to before 3.7.63.7.6Patch availableCNA
  • Dokan VendorUnknown Affected 2.6.8 to before 3.7.6 Fixed in 3.7.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:dokan:dokan:*:*:*:*:lite:wordpress:*:*before 3.7.6VulnerableDokan, Inc.
  • cpe:2.3:a:dokan:dokan:*:*:*:*:lite:wordpress:*:* Versions before 3.7.6 Vulnerable ·Dokan, Inc.

Remediation

  • Fix · CNA Dokan (Unknown) Fixed in 3.7.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-3915
  2. 2026-10-03 Alias added: GHSA-2776-fr3j-r98m

References

  • TI-2024-03660 Dokan Pro <= 3.10.3 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 10.0
  • TI-2022-02949 Dokan < 3.6.4 - Vendor Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
  • TI-2023-17212 WordPress Dokan Plugin <= 3.7.19 is vulnerable to PHP Object Injection CVSS 3.1HIGH 8.8
  • TI-2023-11662 WordPress Dokan Plugin <= 3.7.12 is vulnerable to SQL Injection CVSS 3.1HIGH 8.1
  • TI-2020-18917 Dokan <= 3.0.8 - Cross-Site Request Forgery Bypass CVSS 3.1MEDIUM 4.3

Sources