WP Contact Slider < 2.4.8 - Admin+ Stored Cross-Site Scripting
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Contact Slider WordPress plugin before 2.4.8 does not sanitize and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00667 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP Contact Slider (Unknown): 2.4.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Contact Slider | 2.4.8 to before 2.4.8 | 2.4.8 | Patch available | CNA |
- WP Contact Slider VendorUnknown Affected 2.4.8 to before 2.4.8 Fixed in 2.4.8 Patch available CNA
Remediation
- Fix · CNA WP Contact Slider (Unknown) Fixed in 2.4.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3237
- 2026-10-03 Alias added: GHSA-8xcg-mxrm-jq68
- 2026-10-28 EPSS moved to the 50th–90th percentile
References
More WPExperts Wp Contact Slider vulnerabilities
- TI-2022-01185 WP Contact Slider < 2.4.7 - Editor+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2022-3237 · CVE Program
- CVE-2022-3237 · NVD
- FIRST EPSS
- GHSA-8xcg-mxrm-jq68 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences