LearnPress < 4.1.7.2 - Unauthenticated PHP Object Injection via REST API
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-502.
Summary
The LearnPress WordPress plugin before 4.1.7.2 unserialises user input in a REST API endpoint available to unauthenticated users, which could lead to PHP Object Injection when a suitable gadget is present, leadint to remote code execution (RCE). To successfully exploit this vulnerability attackers must have knowledge of the site secrets, allowing them to generate a valid hash via the wp_hash() function.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | LearnPress – WordPress LMS Plugin | 4.1.7.2 to before 4.1.7.2 | 4.1.7.2 | Patch available | CNA |
- LearnPress – WordPress LMS Plugin VendorUnknown Affected 4.1.7.2 to before 4.1.7.2 Fixed in 4.1.7.2 Patch available CNA
Remediation
- Fix · CNA LearnPress – WordPress LMS Plugin (Unknown) Fixed in 4.1.7.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3360
- 2026-10-03 Alias added: GHSA-7h2h-qrhm-554p
References
More ThimPress Learnpress vulnerabilities
- TI-2024-07900 LearnPress – WordPress LMS Plugin <= 4.2.7 - Unauthenticated SQL Injection via 'c_only_fields' CVSS 3.1CRITICAL 10.0
- TI-2023-06018 LearnPress <= 4.2.5.7 - Unauthenticated SQL Injection via order_by CVSS 3.1CRITICAL 9.8
- TI-2024-04124 LearnPress – WordPress LMS Plugin <= 4.2.6.5 - Unauthenticated Time-Based SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2023-18355 WordPress LearnPress plugin <= 4.2.3 - Authenticated Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2020-04911 LearnPress Wordpress plugin version prior and including 3.2.6.7 is vulnerable to SQL Injection CVSS 3.1HIGH 8.8
- TI-2024-07907 LearnPress – WordPress LMS Plugin <= 4.2.7 - Unauthenticated SQL Injection via 'c_fields' CVSS 3.1CRITICAL 10.0
Sources
- CVE-2022-3360 · CVE Program
- CVE-2022-3360 · NVD
- FIRST EPSS
- GHSA-7h2h-qrhm-554p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences