Read the docs
TI-2022-03225 Aliases CVE-2022-3494GHSA-49q7-gc3f-7wp4

Complianz (Free < 6.3.4, Premium < 6.3.6) - Translator SQLi

Priority HIGH 73CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.

Summary

The Complianz WordPress plugin before 6.3.4, and Complianz Premium WordPress plugin before 6.3.6 allow a translators to inject arbitrary SQL through an unsanitized translation. SQL can be injected through an infected translation file, or by a user with a translator role through translation plugins such as Loco Translate or WPML.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01576 75th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Complianz – GDPR/CCPA Cookie Consent (Unknown): 6.3.4Complianz Premium (Unknown): 6.3.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownComplianz – GDPR/CCPA Cookie Consent6.3.4 to before 6.3.46.3.4Patch availableCNA
UnknownComplianz Premium6.3.6 to before 6.3.66.3.6Patch availableCNA
  • Complianz – GDPR/CCPA Cookie Consent VendorUnknown Affected 6.3.4 to before 6.3.4 Fixed in 6.3.4 Patch available CNA
  • Complianz Premium VendorUnknown Affected 6.3.6 to before 6.3.6 Fixed in 6.3.6 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:really-simple-plugins:complianz:*:*:*:*:-:wordpress:*:*before 6.3.4VulnerableReally Simple Plugins
cpe:2.3:a:really-simple-plugins:complianz:*:*:*:*:premium:wordpress:*:*before 6.3.6VulnerableReally Simple Plugins
  • cpe:2.3:a:really-simple-plugins:complianz:*:*:*:*:-:wordpress:*:* Versions before 6.3.4 Vulnerable ·Really Simple Plugins
  • cpe:2.3:a:really-simple-plugins:complianz:*:*:*:*:premium:wordpress:*:* Versions before 6.3.6 Vulnerable ·Really Simple Plugins

Remediation

  • Fix · CNA Complianz – GDPR/CCPA Cookie Consent (Unknown) Fixed in 6.3.4
  • Fix · CNA Complianz Premium (Unknown) Fixed in 6.3.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-3494
  2. 2026-10-03 Alias added: GHSA-49q7-gc3f-7wp4

References

  • TI-2023-01012 Complianz - GDPR/CCPA Cookie Consent < 6.4.2 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2023-16896 WordPress Complianz and Complianz Premium plugins - Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2023-16492 Cross-site request forgery in Really Simple Plugins Complianz CVSS 3.1HIGH 8.8
  • TI-2022-00132 Complianz - GDPR/CCPA Cookie Consent < 6.0.0 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2023-05955 Complianz | GDPR/CCPA Cookie Consent <= 6.5.5 - Authenticated(Administrator+) Stored Cross-site Scripting via settings CVSS 3.1MEDIUM 4.8
  • TI-2024-01486 Complianz – GDPR/CCPA Cookie Consent <= 6.5.6 - Cross-Site Request Forgery to Data Request Deletion CVSS 3.1MEDIUM 4.3

Sources