Complianz - GDPR/CCPA Cookie Consent < 6.4.2 - Contributor+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The Complianz WordPress plugin before 6.4.2, Complianz Premium WordPress plugin before 6.4.2 do not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Complianz | before 6.4.2 | 6.4.2 | Patch available | CNA |
| Unknown | Complianz Premium | before 6.4.2 | 6.4.2 | Patch available | CNA |
| — | really-simple-plugins/complianz-gdpr (Packagist) | before 6.4.2 | 6.4.2 | Patch available | GHSA-7j4m-f87g-5r9r |
- Complianz VendorUnknown Affected before 6.4.2 Fixed in 6.4.2 Patch available CNA
- Complianz Premium VendorUnknown Affected before 6.4.2 Fixed in 6.4.2 Patch available CNA
- really-simple-plugins/complianz-gdpr (Packagist) Vendor— Affected before 6.4.2 Fixed in 6.4.2 Patch available GHSA-7j4m-f87g-5r9r
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:really-simple-plugins:complianz:*:*:*:*:-:wordpress:*:* | before 6.4.2 | Vulnerable | Really Simple Plugins |
| cpe:2.3:a:really-simple-plugins:complianz:*:*:*:*:premium:wordpress:*:* | before 6.4.2 | Vulnerable | Really Simple Plugins |
- cpe:2.3:a:really-simple-plugins:complianz:*:*:*:*:-:wordpress:*:* Versions before 6.4.2 Vulnerable ·Really Simple Plugins
- cpe:2.3:a:really-simple-plugins:complianz:*:*:*:*:premium:wordpress:*:* Versions before 6.4.2 Vulnerable ·Really Simple Plugins
Remediation
- Fix · CNA Complianz (Unknown) Fixed in 6.4.2
- Fix · CNA Complianz Premium (Unknown) Fixed in 6.4.2
- Fix · GHSA-7j4m-f87g-5r9r really-simple-plugins/complianz-gdpr (Packagist) Fixed in 6.4.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1069
- 2026-10-03 Alias added: GHSA-7j4m-f87g-5r9r
References
More Really Simple Plugins Complianz vulnerabilities
- TI-2022-03225 Complianz (Free < 6.3.4, Premium < 6.3.6) - Translator SQLi CVSS 3.1HIGH 8.8
- TI-2023-16896 WordPress Complianz and Complianz Premium plugins - Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-16492 Cross-site request forgery in Really Simple Plugins Complianz CVSS 3.1HIGH 8.8
- TI-2022-00132 Complianz - GDPR/CCPA Cookie Consent < 6.0.0 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-05955 Complianz | GDPR/CCPA Cookie Consent <= 6.5.5 - Authenticated(Administrator+) Stored Cross-site Scripting via settings CVSS 3.1MEDIUM 4.8
- TI-2024-01486 Complianz – GDPR/CCPA Cookie Consent <= 6.5.6 - Cross-Site Request Forgery to Data Request Deletion CVSS 3.1MEDIUM 4.3
Sources
- CVE-2023-1069 · CVE Program
- CVE-2023-1069 · NVD
- FIRST EPSS
- GHSA-7j4m-f87g-5r9r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences