ProfileGrid < 5.1.1 - Reflected Cross-Site Scripting
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The ProfileGrid WordPress plugin before 5.1.1 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01038 64th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed ProfileGrid – User Profiles, Memberships, Groups and Communities (Unknown): 5.1.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | ProfileGrid – User Profiles, Memberships, Groups and Communities | 5.1.1 to before 5.1.1 | 5.1.1 | Patch available | CNA |
- ProfileGrid – User Profiles, Memberships, Groups and Communities VendorUnknown Affected 5.1.1 to before 5.1.1 Fixed in 5.1.1 Patch available CNA
Remediation
- Fix · CNA ProfileGrid – User Profiles, Memberships, Groups and Communities (Unknown) Fixed in 5.1.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3578
- 2026-10-03 Alias added: GHSA-54p8-p4vv-qvgr
References
More Metagauss Profilegrid vulnerabilities
- TI-2023-00891 ProfileGrid < 5.3.1 - Subscriber+ Arbitrary Password Reset CVSS 3.1HIGH 8.8
- TI-2024-20215 WordPress ProfileGrid – User Profiles, Memberships, Groups and Communities plugin <= 5.7.8 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-20214 WordPress ProfileGrid plugin <= 5.7.8 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-05950 ProfileGrid <= 5.8.9 - Authenticated (Subscriber+) Insecure Direct Object Reference CVSS 3.1MEDIUM 4.3
- TI-2019-11933 The profilegrid-user-profiles-groups-and-communities plugin before 2.8.6 for WordPress… CVSS 3.0HIGH 8.8
- TI-2023-03470 ProfileGrid <= 5.5.2 - Missing Authorization to Arbitrary Group Option Modification and Privilege Escalation CVSS 3.1HIGH 8.8
Sources
- CVE-2022-3578 · CVE Program
- CVE-2022-3578 · NVD
- FIRST EPSS
- GHSA-54p8-p4vv-qvgr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences