User Registration < 2.2.4.1 - Subscriber+ Arbitrary File Upload
Priority HIGH 66CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-434.
Summary
The User Registration WordPress plugin before 2.2.4.1 does not properly restrict the files to be uploaded via an AJAX action available to both unauthenticated and authenticated users, which could allow unauthenticated users to upload PHP files for example.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0078 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed User Registration (Unknown): 2.2.4.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | User Registration | before 2.2.4.1 | 2.2.4.1 | Patch available | CNA |
- User Registration VendorUnknown Affected before 2.2.4.1 Fixed in 2.2.4.1 Patch available CNA
Remediation
- Fix · CNA User Registration (Unknown) Fixed in 2.2.4.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3912
- 2026-10-03 Alias added: GHSA-r7xp-c243-63mm
References
More wpeverest User Registration vulnerabilities
- TI-2023-04806 User Registration < 3.0.4.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-03127 User Registration <= 3.0.2 - Authenticated (Subscriber+) Arbitrary File Upload CVSS 3.1CRITICAL 9.9
- TI-2023-03128 User Registration <= 3.0.1 - Authenticated (Subscriber+) PHP Object Injection CVSS 3.1HIGH 8.8
- TI-2023-13809 WordPress User Registration plugin <= 2.3.2.1 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
- TI-2025-01300 Cross-site scripting in wpeverest User Registration & Membership – Free & Paid… CVSS 3.1MEDIUM 6.1
- TI-2023-09774 WordPress User Registration Plugin <= 2.3.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2022-3912 · CVE Program
- CVE-2022-3912 · NVD
- FIRST EPSS
- GHSA-r7xp-c243-63mm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences