User Registration < 3.0.4.2 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The User Registration WordPress plugin before 3.0.4.2 does not sanitize and escape some of its settings, which could allow high-privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00632 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed User Registration (Unknown): 3.0.4.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | User Registration | before 3.0.4.2 | 3.0.4.2 | Patch available | CNA |
- User Registration VendorUnknown Affected before 3.0.4.2 Fixed in 3.0.4.2 Patch available CNA
Remediation
- Fix · CNA User Registration (Unknown) Fixed in 3.0.4.2
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5228
- 2026-10-03 Alias added: GHSA-cfhf-5qvq-2jgj
- 2026-11-07 EPSS moved to the 50th–90th percentile
References
More wpeverest User Registration vulnerabilities
- TI-2022-03588 User Registration < 2.2.4.1 - Subscriber+ Arbitrary File Upload CVSS 3.1HIGH 7.5
- TI-2023-03127 User Registration <= 3.0.2 - Authenticated (Subscriber+) Arbitrary File Upload CVSS 3.1CRITICAL 9.9
- TI-2023-03128 User Registration <= 3.0.1 - Authenticated (Subscriber+) PHP Object Injection CVSS 3.1HIGH 8.8
- TI-2023-13809 WordPress User Registration plugin <= 2.3.2.1 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
- TI-2025-01300 Cross-site scripting in wpeverest User Registration & Membership – Free & Paid… CVSS 3.1MEDIUM 6.1
- TI-2023-09774 WordPress User Registration Plugin <= 2.3.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2023-5228 · CVE Program
- CVE-2023-5228 · NVD
- FIRST EPSS
- GHSA-cfhf-5qvq-2jgj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences