Read the docs
TI-2023-03127 Aliases CVE-2023-3342GHSA-4q7m-mf5f-23v3

User Registration <= 3.0.2 - Authenticated (Subscriber+) Arbitrary File Upload

Priority MEDIUM 46CWE-434Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.

Summary

The User Registration plugin for WordPress is vulnerable to arbitrary file uploads due to a hardcoded encryption key and missing file type validation on the 'ur_upload_profile_pic' function in versions up to, and including, 3.0.2. This makes it possible for authenticated attackers with subscriber-level capabilities or above to upload arbitrary files on the affected site's server which may make remote code execution possible. This was partially patched in version 3.0.2 and fully patched in version 3.0.2.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01691 77th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
wpeverestUser Registration & Membership – Free & Paid Memberships, Subscriptions, Content Restriction, User Profile, Custom User Registration & Login Builderup to 3.0.2—No fix listedCNA
  • User Registration & Membership – Free & Paid Memberships, Subscriptions, Content Restriction, User Profile, Custom User Registration & Login Builder Vendorwpeverest Affected up to 3.0.2 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpeverest:user_registration:*:*:*:*:*:wordpress:*:*before 3.0.2.1Vulnerablewpeverest
  • cpe:2.3:a:wpeverest:user_registration:*:*:*:*:*:wordpress:*:* Versions before 3.0.2.1 Vulnerable ·wpeverest

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-3342
  2. 2026-10-03 Alias added: GHSA-4q7m-mf5f-23v3

References

  • TI-2022-03588 User Registration < 2.2.4.1 - Subscriber+ Arbitrary File Upload CVSS 3.1HIGH 7.5
  • TI-2023-04806 User Registration < 3.0.4.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2023-03128 User Registration <= 3.0.1 - Authenticated (Subscriber+) PHP Object Injection CVSS 3.1HIGH 8.8
  • TI-2023-13809 WordPress User Registration plugin <= 2.3.2.1 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
  • TI-2025-01300 Cross-site scripting in wpeverest User Registration & Membership – Free & Paid… CVSS 3.1MEDIUM 6.1
  • TI-2023-09774 WordPress User Registration Plugin <= 2.3.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
See all 7 →

Sources