Carousel, Slider, Gallery by WP Carousel < 2.5.3 - Contributor+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Carousel, Slider, Gallery by WP Carousel WordPress plugin before 2.5.3 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Carousel, Slider, Gallery by WP Carousel | before 2.5.3 | 2.5.3 | Patch available | CNA |
- Carousel, Slider, Gallery by WP Carousel VendorUnknown Affected before 2.5.3 Fixed in 2.5.3 Patch available CNA
Remediation
- Fix · CNA Carousel, Slider, Gallery by WP Carousel (Unknown) Fixed in 2.5.3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4482
- 2026-10-03 Alias added: GHSA-3xpp-cq9m-3ppc
References
More Techearty Carousel, Slider, Gallery By Wp Carousel vulnerabilities
- TI-2024-12358 Carousel, Slider, Gallery by WP Carousel < 2.7.4 - Admin+ Stored XSS CVSS 3.1LOW 3.5
- TI-2024-03734 Carousel, Slider, Gallery by WP Carousel < 2.6.9 - Editor+ Stored XSS CVSS 3.1LOW 3.5
Sources
- CVE-2022-4482 · CVE Program
- CVE-2022-4482 · NVD
- FIRST EPSS
- GHSA-3xpp-cq9m-3ppc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences