Carousel, Slider, Gallery by WP Carousel < 2.6.9 - Editor+ Stored XSS
Priority MEDIUM 50CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Carousel, Slider, Gallery by WP Carousel WordPress plugin before 2.6.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00355 29th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Carousel, Slider, Gallery by WP Carousel (Unknown): 2.6.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Carousel, Slider, Gallery by WP Carousel | before 2.6.9 | 2.6.9 | Patch available | CNA |
- Carousel, Slider, Gallery by WP Carousel VendorUnknown Affected before 2.6.9 Fixed in 2.6.9 Patch available CNA
Remediation
- Fix · CNA Carousel, Slider, Gallery by WP Carousel (Unknown) Fixed in 2.6.9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4002
- 2026-10-03 Alias added: GHSA-gpv2-32pf-74f2
References
More Techearty Carousel, Slider, Gallery By Wp Carousel vulnerabilities
- TI-2022-04097 Carousel, Slider, Gallery by WP Carousel < 2.5.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-12358 Carousel, Slider, Gallery by WP Carousel < 2.7.4 - Admin+ Stored XSS CVSS 3.1LOW 3.5
Sources
- CVE-2024-4002 · CVE Program
- CVE-2024-4002 · NVD
- FIRST EPSS
- GHSA-gpv2-32pf-74f2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences