TemplatesNext ToolKit < 3.2.8 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The TemplatesNext ToolKit WordPress plugin before 3.2.8 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0054 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed TemplatesNext ToolKit (Unknown): 3.2.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | TemplatesNext ToolKit | before 3.2.8 | 3.2.8 | Patch available | CNA |
- TemplatesNext ToolKit VendorUnknown Affected before 3.2.8 Fixed in 3.2.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:templatesnext:templatesnext_toolkit:*:*:*:*:*:wordpress:*:* | before 3.2.8 | Vulnerable | TemplatesNext |
- cpe:2.3:a:templatesnext:templatesnext_toolkit:*:*:*:*:*:wordpress:*:* Versions before 3.2.8 Vulnerable ·TemplatesNext
Remediation
- Fix · CNA TemplatesNext ToolKit (Unknown) Fixed in 3.2.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4678
- 2026-10-03 Alias added: GHSA-mchv-7c6q-8f6p
References
More Templatesnext Toolkit vulnerabilities
- TI-2023-00317 TemplatesNext ToolKit < 3.2.9 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2023-08887 WordPress TemplatesNext ToolKit Plugin <= 3.2.7 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-4678 · CVE Program
- CVE-2022-4678 · NVD
- FIRST EPSS
- GHSA-mchv-7c6q-8f6p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences