TemplatesNext ToolKit < 3.2.9 - Contributor+ Stored XSS
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The TemplatesNext ToolKit WordPress plugin before 3.2.9 does not validate some of its shortcode attributes before using them to generate an HTML tag, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0049 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed TemplatesNext ToolKit (Unknown): 3.2.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | TemplatesNext ToolKit | before 3.2.9 | 3.2.9 | Patch available | CNA |
- TemplatesNext ToolKit VendorUnknown Affected before 3.2.9 Fixed in 3.2.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:templatesnext:templatesnext_toolkit:*:*:*:*:*:wordpress:*:* | before 3.2.9 | Vulnerable | TemplatesNext |
- cpe:2.3:a:templatesnext:templatesnext_toolkit:*:*:*:*:*:wordpress:*:* Versions before 3.2.9 Vulnerable ·TemplatesNext
Remediation
- Fix · CNA TemplatesNext ToolKit (Unknown) Fixed in 3.2.9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0333
- 2026-10-03 Alias added: GHSA-j67r-9w4c-jhx6
References
More Templatesnext Toolkit vulnerabilities
- TI-2022-04276 TemplatesNext ToolKit < 3.2.8 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
- TI-2023-08887 WordPress TemplatesNext ToolKit Plugin <= 3.2.7 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-0333 · CVE Program
- CVE-2023-0333 · NVD
- FIRST EPSS
- GHSA-j67r-9w4c-jhx6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences