Cross-site scripting in Octopus Server
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
In affected versions of Octopus Server the help sidebar can be customized to include a Cross-Site Scripting payload in the support link. This was initially resolved in advisory 2022-07 however it was identified that the fix could be bypassed in certain circumstances. A different approach was taken to prevent the possibility of the support link being susceptible to XSS
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 2019.7.0 and later; before 2022.2.8552; 2022.3.348 and later; before 2022.3.10750; 2022.4.791 and later; before 2022.4.8319 | 2022.2.8552, 2022.3.10750, 2022.4.8319 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 2019.7.0 and later; before 2022.2.8552; 2022.3.348 and later; before 2022.3.10750; 2022.4.791 and later; before 2022.4.8319 Fixed in 2022.2.8552, 2022.3.10750, 2022.4.8319 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* | 2019.7.0 to before 2022.2.8552; 2022.3.348 to before 2022.3.10750; 2022.4.791 to before 2022.4.8319 | Vulnerable | Octopus Deploy |
- cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* Versions 2019.7.0 to before 2022.2.8552; 2022.3.348 to before 2022.3.10750; 2022.4.791 to before 2022.4.8319 Vulnerable ·Octopus Deploy
Remediation
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2022.2.8552, 2022.3.10750, 2022.4.8319
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4898
- 2026-10-03 Alias added: GHSA-4gvq-c37w-77wr
References
More Octopus Deploy Octopus Server vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
- TI-2022-03678 In affected versions of Octopus Deploy it is possible for a user to introduce code via offline package creation CVSS 3.1HIGH 8.8
Sources
- CVE-2022-4898 · CVE Program
- CVE-2022-4898 · NVD
- FIRST EPSS
- GHSA-4gvq-c37w-77wr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences