Insufficient Session Expiration in shopware
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-613.
Summary
Shopware is an open source e-commerce software platform. In affected versions shopware would not invalidate a user session in the event of a password change. With version 5.7.7 the session validation was adjusted, so that sessions created prior to the latest password change of a customer account can't be used to login with said account. This also means, that upon a password change, all existing sessions for a given customer account are automatically considered invalid. There is no workaround for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| shopware | shopware | 5.7.3 to before 5.7.7 | 5.7.7 | Patch available | CNA |
| — | shopware/shopware (Packagist) | 5.7.3 to before 5.7.7 | 5.7.7 | Patch available | GHSA-p523-jrph-qjc6 |
- shopware Vendorshopware Affected 5.7.3 to before 5.7.7 Fixed in 5.7.7 Patch available CNA
- shopware/shopware (Packagist) Vendor— Affected 5.7.3 to before 5.7.7 Fixed in 5.7.7 Patch available GHSA-p523-jrph-qjc6
Remediation
- Fix · CNA shopware (shopware) Fixed in 5.7.7
- Fix · GHSA-p523-jrph-qjc6 shopware/shopware (Packagist) Fixed in 5.7.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-21652
- 2026-10-03 Alias added: GHSA-p523-jrph-qjc6
References
Patch 3
More Shopware vulnerabilities
- TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
- TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
- TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
- TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
- TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
- TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-21652 · CVE Program
- CVE-2022-21652 · NVD
- FIRST EPSS
- GHSA-p523-jrph-qjc6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences