SSRF vulnerability (requires authentication)
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Jupyter Server Proxy is a Jupyter notebook server extension to proxy web services. Versions of Jupyter Server Proxy prior to 3.2.1 are vulnerable to Server-Side Request Forgery (SSRF). Any user deploying Jupyter Server or Notebook with jupyter-proxy-server extension enabled is affected. A lack of input validation allows authenticated clients to proxy requests to other hosts, bypassing the `allowed_hosts` check. Because authentication is required, which already grants permissions to make the same requests via kernel or terminal execution, this is considered low to moderate severity. Users may upgrade to version 3.2.1 to receive a patch or, as a workaround, install the patch manually.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jupyterhub | jupyter-server-proxy | before 3.2.1 | 3.2.1 | Patch available | CNA |
| — | jupyter-server-proxy (PyPI) | before 3.2.1 | 3.2.1 | Patch available | GHSA-gcv9-6737-pjqw |
- jupyter-server-proxy Vendorjupyterhub Affected before 3.2.1 Fixed in 3.2.1 Patch available CNA
- jupyter-server-proxy (PyPI) Vendor— Affected before 3.2.1 Fixed in 3.2.1 Patch available GHSA-gcv9-6737-pjqw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jupyter:jupyter_server_proxy:*:*:*:*:*:*:*:* | before 3.2.1 | Vulnerable | jupyterlab |
- cpe:2.3:a:jupyter:jupyter_server_proxy:*:*:*:*:*:*:*:* Versions before 3.2.1 Vulnerable ·jupyterlab
Remediation
- Fix · CNA jupyter-server-proxy (jupyterhub) Fixed in 3.2.1
- Fix · GHSA-gcv9-6737-pjqw jupyter-server-proxy (PyPI) Fixed in 3.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-21697
- 2026-10-03 Alias added: GHSA-gcv9-6737-pjqw
References
Patch 2
Advisory 2
More jupyterhub vulnerabilities
- TI-2025-23499 Jupyter Remote Desktop Proxy makes TigerVNC accessible via the network and not just via a UNIX socket as intended CVSS 4.0CRITICAL 9.0
- TI-2023-10877 JupyterHub's LTI13Authenticator: JWT signature not validated CVSS 3.1CRITICAL 10.0
- TI-2021-16545 Remote code execution in Binderhub CVSS 3.1CRITICAL 9.8
- TI-2021-18033 Improper Access Control in jupyterhub-firstuseauthenticator CVSS 3.1CRITICAL 9.8
- TI-2021-16546 Code injection in nbgitpuller CVSS 3.1CRITICAL 9.6
- TI-2024-18755 Jupyter Server Proxy's Websocket Proxying does not require authentication CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-21697 · CVE Program
- CVE-2022-21697 · NVD
- FIRST EPSS
- GHSA-gcv9-6737-pjqw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences