Shopizer - Stored XSS in Manage Images
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A Stored Cross Site Scripting (XSS) vulnerability exists in Shopizer versions 2.0 through 2.17.0 via the “Manage Images” tab, which allows an attacker to upload a SVG file containing malicious JavaScript code.
Why it matters now
EPSS 0.00624 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed com.shopizer:shopizer (Maven): 3.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| shopizer-ecommerce | Shopizer | 2.0 and later; up to 2.17.0 | — | No fix listed | CNA |
| — | com.shopizer:shopizer (Maven) | 2.0.2 to before 3.0.0 | 3.0.0 | Patch available | GHSA-p2j7-6g9h-32xh |
- Shopizer Vendorshopizer-ecommerce Affected 2.0 and later; up to 2.17.0 Fixed in — No fix listed CNA
- com.shopizer:shopizer (Maven) Vendor— Affected 2.0.2 to before 3.0.0 Fixed in 3.0.0 Patch available GHSA-p2j7-6g9h-32xh
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:shopizer:shopizer:*:*:*:*:*:*:*:* | 2.0 – 2.17.0 | Vulnerable | shopizer-ecommerce |
- cpe:2.3:a:shopizer:shopizer:*:*:*:*:*:*:*:* Versions 2.0 – 2.17.0 Vulnerable ·shopizer-ecommerce
Remediation
- Fix · GHSA-p2j7-6g9h-32xh com.shopizer:shopizer (Maven) Fixed in 3.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23059
- 2026-10-03 Alias added: GHSA-p2j7-6g9h-32xh
- 2026-11-04 EPSS moved to the 50th–90th percentile
References
More shopizer-ecommerce Shopizer vulnerabilities
- TI-2025-32372 An issue was discovered in Shopizer 3.2.7. CVSS 3.1HIGH 8.1
- TI-2022-07236 Shopizer - Insufficient Session Expiration CVSS 3.1HIGH 8.8
- TI-2020-08880 Potential remote code execution in Shopizer CVSS 3.1CRITICAL 9.1
- TI-2014-04073 Shopizer 1.1.5 and earlier allows remote attackers to modify the account settings of… CVSS 2.0MEDIUM 6.8
- TI-2014-04072 Shopizer 1.1.5 and earlier allows remote attackers to reduce the total cost of their… CVSS 2.0MEDIUM 6.4
- TI-2014-04074 Multiple cross-site request forgery (CSRF) vulnerabilities in Shopizer 1.1.5 and earlier… CVSS 2.0MEDIUM 6.8
Sources
- CVE-2022-23059 · CVE Program
- CVE-2022-23059 · NVD
- FIRST EPSS
- GHSA-p2j7-6g9h-32xh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences