Read the docs
TI-2022-07638 Aliases CVE-2022-23585GHSA-fq6p-6334-8gr4

Memory leak in decoding PNG images in Tensorflow

Priority MEDIUM 62CWE-401Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-401.

Summary

Tensorflow is an Open Source Machine Learning Framework. When decoding PNG images TensorFlow can produce a memory leak if the image is invalid. After calling `png::CommonInitDecode(..., &decode)`, the `decode` value contains allocated buffers which can only be freed by calling `png::CommonFreeDecode(&decode)`. However, several error case in the function implementation invoke the `OP_REQUIRES` macro which immediately terminates the execution of the function, without allowing for the memory free to occur. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01 63rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tensorflow (tensorflow): 2.5.3, 2.6.3, 2.7.1tensorflow (PyPI): 2.5.3, 2.6.3, 2.7.1+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflowbefore 2.5.3; 2.6.0 to before 2.6.3; 2.7.0 to before 2.7.12.5.3, 2.6.3, 2.7.1Patch availableCNA
—tensorflow (PyPI)before 2.5.32.5.3Patch availableGHSA-fq6p-6334-8gr4
—tensorflow (PyPI)2.6.0 to before 2.6.32.6.3Patch availableGHSA-fq6p-6334-8gr4
—tensorflow (PyPI)2.7.0 to before 2.7.12.7.1Patch availableGHSA-fq6p-6334-8gr4
—tensorflow-cpu (PyPI)before 2.5.32.5.3Patch availableGHSA-fq6p-6334-8gr4
—tensorflow-cpu (PyPI)2.6.0 to before 2.6.32.6.3Patch availableGHSA-fq6p-6334-8gr4
—tensorflow-cpu (PyPI)2.7.0 to before 2.7.12.7.1Patch availableGHSA-fq6p-6334-8gr4
—tensorflow-gpu (PyPI)before 2.5.32.5.3Patch availableGHSA-fq6p-6334-8gr4
—tensorflow-gpu (PyPI)2.6.0 to before 2.6.32.6.3Patch availableGHSA-fq6p-6334-8gr4
—tensorflow-gpu (PyPI)2.7.0 to before 2.7.12.7.1Patch availableGHSA-fq6p-6334-8gr4
  • tensorflow VendorGoogle Affected before 2.5.3; 2.6.0 to before 2.6.3; 2.7.0 to before 2.7.1 Fixed in 2.5.3, 2.6.3, 2.7.1 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 2.5.3 Fixed in 2.5.3 Patch available GHSA-fq6p-6334-8gr4
  • tensorflow (PyPI) Vendor— Affected 2.6.0 to before 2.6.3 Fixed in 2.6.3 Patch available GHSA-fq6p-6334-8gr4
  • tensorflow (PyPI) Vendor— Affected 2.7.0 to before 2.7.1 Fixed in 2.7.1 Patch available GHSA-fq6p-6334-8gr4
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.5.3 Fixed in 2.5.3 Patch available GHSA-fq6p-6334-8gr4
  • tensorflow-cpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.3 Fixed in 2.6.3 Patch available GHSA-fq6p-6334-8gr4
  • tensorflow-cpu (PyPI) Vendor— Affected 2.7.0 to before 2.7.1 Fixed in 2.7.1 Patch available GHSA-fq6p-6334-8gr4
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.5.3 Fixed in 2.5.3 Patch available GHSA-fq6p-6334-8gr4
  • tensorflow-gpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.3 Fixed in 2.6.3 Patch available GHSA-fq6p-6334-8gr4
  • tensorflow-gpu (PyPI) Vendor— Affected 2.7.0 to before 2.7.1 Fixed in 2.7.1 Patch available GHSA-fq6p-6334-8gr4

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*up to 2.5.2; 2.6.0 – 2.6.2VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.7.0:*:*:*:*:*:*:*2.7.0VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions up to 2.5.2; 2.6.0 – 2.6.2 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.5.3, 2.6.3, 2.7.1
  • Fix · GHSA-fq6p-6334-8gr4 tensorflow (PyPI) Fixed in 2.5.3 Advisory →
  • Fix · GHSA-fq6p-6334-8gr4 tensorflow (PyPI) Fixed in 2.6.3 Advisory →
  • Fix · GHSA-fq6p-6334-8gr4 tensorflow (PyPI) Fixed in 2.7.1 Advisory →
  • Fix · GHSA-fq6p-6334-8gr4 tensorflow-cpu (PyPI) Fixed in 2.5.3 Advisory →
  • Fix · GHSA-fq6p-6334-8gr4 tensorflow-cpu (PyPI) Fixed in 2.6.3 Advisory →
  • Fix · GHSA-fq6p-6334-8gr4 tensorflow-cpu (PyPI) Fixed in 2.7.1 Advisory →
  • Fix · GHSA-fq6p-6334-8gr4 tensorflow-gpu (PyPI) Fixed in 2.5.3 Advisory →
  • Fix · GHSA-fq6p-6334-8gr4 tensorflow-gpu (PyPI) Fixed in 2.6.3 Advisory →
  • Fix · GHSA-fq6p-6334-8gr4 tensorflow-gpu (PyPI) Fixed in 2.7.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-23585
  2. 2026-10-03 Alias added: GHSA-fq6p-6334-8gr4

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources