Read the docs
TI-2022-07646 Aliases CVE-2022-23593GHSA-gwcx-jrx4-92w2

Segfault in `simplifyBroadcast` in Tensorflow

Priority HIGH 66CWE-754Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Tensorflow is an Open Source Machine Learning Framework. The `simplifyBroadcast` function in the MLIR-TFRT infrastructure in TensorFlow is vulnerable to a segfault (hence, denial of service), if called with scalar shapes. If all shapes are scalar, then `maxRank` is 0, so we build an empty `SmallVector`. The fix will be included in TensorFlow 2.8.0. This is the only affected version.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0087 59th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tensorflow (tensorflow): 2.8.0tensorflow (PyPI): 2.8.0+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflow2.7.0 to before 2.8.02.8.0Patch availableCNA
—tensorflow (PyPI)2.8.0-rc0 to before 2.8.02.8.0Patch availableGHSA-gwcx-jrx4-92w2
—tensorflow-cpu (PyPI)2.8.0-rc0 to before 2.8.02.8.0Patch availableGHSA-gwcx-jrx4-92w2
—tensorflow-gpu (PyPI)2.8.0-rc0 to before 2.8.02.8.0Patch availableGHSA-gwcx-jrx4-92w2
  • tensorflow VendorGoogle Affected 2.7.0 to before 2.8.0 Fixed in 2.8.0 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected 2.8.0-rc0 to before 2.8.0 Fixed in 2.8.0 Patch available GHSA-gwcx-jrx4-92w2
  • tensorflow-cpu (PyPI) Vendor— Affected 2.8.0-rc0 to before 2.8.0 Fixed in 2.8.0 Patch available GHSA-gwcx-jrx4-92w2
  • tensorflow-gpu (PyPI) Vendor— Affected 2.8.0-rc0 to before 2.8.0 Fixed in 2.8.0 Patch available GHSA-gwcx-jrx4-92w2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*2.7.0 to before 2.8.0VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.7.0 to before 2.8.0 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.8.0
  • Fix · GHSA-gwcx-jrx4-92w2 tensorflow (PyPI) Fixed in 2.8.0 Advisory →
  • Fix · GHSA-gwcx-jrx4-92w2 tensorflow-cpu (PyPI) Fixed in 2.8.0 Advisory →
  • Fix · GHSA-gwcx-jrx4-92w2 tensorflow-gpu (PyPI) Fixed in 2.8.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-23593
  2. 2026-10-03 Alias added: GHSA-gwcx-jrx4-92w2

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources