Improper Privilege Management in GitHub Enterprise Server leading to page creation and deletion
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-269.
Summary
An improper privilege management vulnerability was identified in GitHub Enterprise Server that allowed users with improper privileges to create or delete pages via the API. To exploit this vulnerability, an attacker would need to be added to an organization's repo with write permissions. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.7 and was fixed in versions 3.2.20, 3.3.15, 3.4.10, 3.5.7, and 3.6.3. This vulnerability was reported via the GitHub Bug Bounty program.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitHub | GitHub Enterprise Server | 3.2 to before 3.2.20; 3.3 to before 3.3.15; 3.4 to before 3.4.10; 3.5 to before 3.5.7; 3.6 to before 3.6.3 | 3.2.20, 3.3.15, 3.4.10, 3.5.7, 3.6.3 | Patch available | CNA |
- GitHub Enterprise Server VendorGitHub Affected 3.2 to before 3.2.20; 3.3 to before 3.3.15; 3.4 to before 3.4.10; 3.5 to before 3.5.7; 3.6 to before 3.6.3 Fixed in 3.2.20, 3.3.15, 3.4.10, 3.5.7, 3.6.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* | before 3.2.20; 3.3.0 to before 3.3.15; 3.4.0 to before 3.4.10; 3.5.0 to before 3.5.7; 3.6.0 to before 3.6.3 | Vulnerable | GitHub |
- cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* Versions before 3.2.20; 3.3.0 to before 3.3.15; 3.4.0 to before 3.4.10; 3.5.0 to before 3.5.7; 3.6.0 to before 3.6.3 Vulnerable ·GitHub
Remediation
- Fix · CNA GitHub Enterprise Server (GitHub) Fixed in 3.2.20, 3.3.15, 3.4.10, 3.5.7, 3.6.3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23737
- 2026-10-03 Alias added: GHSA-2pm2-h49w-3rj5
References
Other 5
- https://docs.github.com/en/enterprise-server%403.2/admin/release-notes#3.2.20
- https://docs.github.com/en/enterprise-server%403.3/admin/release-notes#3.3.15
- https://docs.github.com/en/enterprise-server%403.4/admin/release-notes#3.4.10
- https://docs.github.com/en/enterprise-server%403.5/admin/release-notes#3.5.7
- https://docs.github.com/en/enterprise-server%403.6/admin/release-notes#3.6.3
More GitHub Enterprise Server vulnerabilities
- TI-2024-04632 An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES)… CVSS 4.0CRITICAL 10.0
- TI-2024-00181 Unsafe Reflection in Github Enterprise Server leading to Command Injection CVSS 3.1CRITICAL 9.8
- TI-2024-00466 Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server CVSS 3.1HIGH 8.8
- TI-2026-03340 Remote code execution via git push option injection in GitHub Enterprise Server CVSS 4.0HIGH 8.7
- TI-2024-08804 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
- TI-2026-08177 Server-side request forgery in GitHub Enterprise Server CVSS 4.0CRITICAL 9.2
Sources
- CVE-2022-23737 · CVE Program
- CVE-2022-23737 · NVD
- FIRST EPSS
- GHSA-2pm2-h49w-3rj5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences